27th July 2017

Student Print Server Upgrade, scheduled 6 years ago

Update: Maintenance has been completed and service has been restored. Please contact ITS at 650-5000 to report any issues.


UPDATE: 8:31am Maintenance is running over and should be completed shortly.


The student print server will be upgraded on Friday, August 4th from 7:30 - 8:00AM. During this time sending and retrieving print jobs will not be possible. Student print services will return to normal by 8:00AM. After the upgrade there should be no noticeable changes to users of the system.